macOS Safari - Site Hangs

Member
Joined
Feb 6, 2018
Messages
23
When loading a page, the site hangs. It does not timeout or refuse the connection—it simply stays blank trying to load.

This problem occurs in both the forums and the main site, and the behavior seems isolated to Safari for macOS. I have encountered this issue in both regular Safari (whatsmybrowser.org/b/A6Y51), as well as Safari Technology Preview (whatsmybrowser.org/b/0VB7D).

Things that have not worked: clearing cache, disabling extensions, and switching user agents.

The site is fine on Safari for iOS (on the same network), as well as for other macOS browsers (Chrome and Firefox tested), so I don’t think it’s a cert or IP problem.
 
Last edited:
Head Contributor Wrangler
Staff
Super Moderator
Joined
Jan 18, 2018
Messages
1,782
A blank page generally means a script that's vital for rendering the page has either been blocked or isn't supported.
 
Member
Joined
Feb 6, 2018
Messages
23
A blank page generally means a script that's vital for rendering the page has either been blocked or isn't supported.
Thanks for the intel. Quick correction on my original post: for what it’s worth, it’s not necessarily that it loads a blank page so much as the MD page just never loads. The progress bar indicates that it is still loading, but it does not move past the page it’s currently on (like if I’m on a new tab or on a different website and try to go to mangadex.org).

I’ve also disabled all content/ad blocking and other extensions and used private windows—none of which seem to make a difference.

Edit: resetting modem and flushing DNS cache do not solve the issue. Also, status.mangadex.org loads fine, but trying to visit the main site or forums results in nothing. The console shows no network requests or errors when trying to visit the main site or forums, which is odd.
 
Last edited:
Member
Joined
Feb 6, 2018
Messages
23
Nothing update again: I set up a clean instance of Safari on a different user on my machine. It has the same issue: trying to go to the mangadex.org URL results in no network activity in the console.

Edit: images are also not loading when trying to pull up a chapter in cubari.moe.
 
Last edited:
Member
Joined
Feb 6, 2018
Messages
23
Well, I figure I might as well document updates for posterity, even though I don’t know what’s happening. To the best of my knowledge, I have made no notable changes to settings or configurations, but I am now able to view images from the uploads subdomain through cubari.moe. Access to the main site and forums subdomain still remain unavailable.

Edit: Main site and forum work in a private mode now, too. Still unable to access through a normal session, even with all extensions turned off, cache deleted, and restarting the browser).
 
Last edited:
Joined
Dec 12, 2023
Messages
1
Hello guys,
I don't know why too but mangadex don't works on my safari, using ipad or using iphone.

edit: in iPad i can't access using any browser, using iphone works only in safari in private
 
Last edited:

Users who are viewing this thread

Top